HELP roof malfunction/weird operation: 43/44 Drive, cowl panel, open circuit


New Member
I just purchased my first Z4 sight unseen. I sent a friend to test it and he said the roof worked normally when he tried it.

However, upon receiving it the roof works completely wacky, almost backwards:

This is similar/same to a previous post, but with no solution:

  • Upon pressing the open button, the latches disengage, but it gets stuck and makes a buzzing noise.
  • To continue opening, one must spam the open and close buttons to open it. AND keep the CLOSE button pressed to open.
  • Upon fully opening, the buzzing noise continues.
  • To reopen, the buttons must be spammed a few times and the latches disengage. AND keep the open button pressed to close.
  • To relatch, one must switch from pressing open to close. AND press the roof forward to engage as it doesn’t go forward enough and line up.



Operation with scanner connected:

It throws two codes from the roof module: 43 and 44, both reading Drive, cowl panel, open circuit.

Would anyone have any advice on how I can start diagnosing?
I was attempting to follow this thread but its almost impossible without pictures.

If there’s any more info needed, or videos/pics that could help let me know!

Thanks to everyone in advance!